«

»

Feb 21

Cisco ASA 8.4 on GNS3

I struggled quite a lot of get ASA 8.4 working on GNS3. I had 8.0(2) working and was helping to test the configurations and VPNs but now wanted to get 8.4 running such that I can prepare myself for new NAT statements and migration from 8.0(2) to 8.4(2).

Here are the steps to get it working. All links to any images or keys are removed for legal reasons. Once its gone its gone.

1. Download the ASA 8.4 files for GNS3 from the following address

I am afraid you will have to search google for reputable sources to get firewall ASA842 image. Please dont ask here for the image.

2. Configure GNS3 as following. ( I am using Ver 0.8.2 Beta 2, Also Tested 8.3 with Windows 7 64 bit which worked without any issues).  Type the code below into relevant fields

 

Qemu Options: -vnc none -vga none -m 1024 -icount auto -hdachs 980,16,32
Kernel cmd line: -append ide_generic.probe_mask=0x01 ide_core.chs=0.0:980,16,32 auto nousb console=ttyS0,9600 bigphysarea=65536
 
Configure the paths for Initrd and Kernel to where you have extracted the files.
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Once the firewall is up and running use following activation keys

Again the activation keys are in public domain so get it using your search capabilities.

 

It will take a while (10-15 min) to accept the second activation key and will take the same time at first reboot.

That's all done and we have a working firewall to play with.

 

 

Now if you want to run two ASAs, you will have to change the Qemu options on the second firewall as below

Qemu Options: -vnc :2 none -vga none -m 1024 -icount auto -hdachs 980,16,32

 

Troubleshooting:

Please check the comments at the end of post where you will find different ways to resolve issues if you face any. Specially very helpfull comments from GD and are detailed below

 

Download and install the latest version of GNS3 0.8.2 after that download the •Qemu 0.13.0 patched 32 bits binary for Windows from
 
 
Copy and replace all downloaded qemu files and folders with existing qemu files and folders under GNS3 folder.

 

After you have ASA running in GNS and want to play with ASDM, here is the guide to follow

http://www.xerunetworks.com/2012/03/asa-84-asdm-on-gns3-step-by-step-guide/

 

and if you want to connect two GNS3 networks running on two different PCs, use following

http://www.xerunetworks.com/2012/03/connect-gns3-network-to-real-networks-other-gns3-network/

I have posted a LAB Guide for migrating NAT from 8.2 to 8.3/8.4 Version, which is still work in progress but has a lot of stuff already added into it

http://www.xerunetworks.com/2012/03/asa-8384-nat-migration-lab-guide/

349 comments

13 pings

Skip to comment form

  1. Archie

    Have a problem with my ASA in gns3, when I try to set up Vlan1, I keep on getting a message saying cannot create management interface, any suggestions?

  2. thanks

    hi , I just tried it it was working fine. Well, it still is but when I started GNS3 again I had to again put activation codes to enable those features. Do I need to go through the process every time I start new Project or is there a shortcut how to save it and skip it?

  3. Ruth

    Please I have the “connection lost” error and I have tried everything suggested but it is still not working. I am using xp just for this purpose. ASA842 when dragged gave the error but gns3 works fine. Don’t know how to resolve the problem. Please help.

  4. SK MINHAJ

    Thanksssssssssssssssss you very much …

  5. James Smith

    This isn’t working. I followed every thing and I AM GETTING THAT ERROR. CONNECTION REFUSED. How can one resolve the ASA’s connection refusal with any node?

  6. uday

    it is giving an error
    ” network error,connection refused ”

    someone pls help!!!

    1. guyso

      HI uday!

      I had the same problem and i resolve it by using directly GNS3-0.8.5 . good luck

      1. uday

        Hi guyso

        Even i tried all this with 0.8.5 version of gns3.. but could nt resolve this.. tried various workarounds on google.. but no luck!!

        1. Simon

          Hi, had the same problem. It was because of a typo in the ASA configuration. Could you check if there is any information in the stderr.txt file in the GNS3 folder (where the qemu binary is situated). I also use GNS3 0.8.5 with Windows 7 x64 and connecting the ASA works now (without any patches etc.)

    2. Saeed

      For network connection error: kindly disabled your NIC and then check it i had this problem and was fight last two days so found this solution with 0.8.5 version x 64bit windows.

  7. Fer

    hi team…it is working on my GNS3 thanks for sharing!!!

  8. Usmaan Malik

    I have a strange issue with my ASA, there is no global default inspection policy in there. Any help please?

    1. jays

      me too..have you figured it out?

      1. Usmaan Malik

        Yes actually i did. Just erase ur startup config after its done booting thn let it reload. Hopefully you will see the default policies.

        1. jays

          Thanks Usmaan, I’ll try it. Hope it works for me.

          1. Usmaan Malik

            Put this command “wr erase” it will ask you to confirm the action. Press y and that should do it.

  9. raghu

    it is giving an error
    ” network error,connection refused ”

    this is the same error i am facing in xp and win 8..

  10. darkplayer

    THANK YOU….. I’ve been trying to get this thing to work for a few days. I knew the command line was the key but every site I went just didn’t have it.

1 15 16 17 18 19 21

Leave a Reply to rick Cancel reply

%d bloggers like this: